Account management emails are not delivered
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 29, 2018 - 08:27 PDT
Identified
Password reset and other account management emails are not reaching some customers due to email delivery service malfunction. We are working on resolving the issue.
Posted about 1 year ago. Aug 29, 2018 - 08:02 PDT
This incident affected: Logi ID.