Squeezebox Player connection disturbed in the US
Incident Report for Logitech
Resolved
A fix has been implemented and the service appears to be functioning as expected.
Posted over 1 year ago. Apr 11, 2018 - 18:17 PDT
Investigating
We're seeing some issues in the US where players would fail to connect.
Posted over 1 year ago. Apr 11, 2018 - 14:48 PDT
This incident affected: Squeezebox (Player Connection (US)).