Logitech Circle: Service Issue with Circle 1 Cameras
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted Dec 19, 2024 - 17:24 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2024 - 11:45 PST
Identified
We have identified an issue with Circle 1 cameras not being able to connect and are working on a fix.
Posted Dec 17, 2024 - 11:01 PST
This incident affected: Circle (Video Recording).