mysqueezebox.com EU down
Incident Report for Logitech
Resolved
We're back on track!
Posted 14 days ago. Oct 07, 2019 - 10:05 PDT
Monitoring
Devices seem to reconnect successfully now. If yours doesn't work correctly then please restart it.
Posted 14 days ago. Oct 07, 2019 - 08:38 PDT
Update
Unfortunately the infrastructure can't handle the in-rush of the reconnecting devices. We're working to get the situation under control.
Posted 14 days ago. Oct 07, 2019 - 07:01 PDT
Investigating
We're currently experiencing extremely high load in our EU datacenters.
Posted 14 days ago. Oct 07, 2019 - 00:02 PDT
This incident affected: Squeezebox (Player Connection (EU)).