Web Client Performance Issue
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 20, 2018 - 20:46 PDT
Investigating
We are investigating an issue with the circle web client which causes live video to be choppy or stall and scrolling through the list of activities to flicker and jump.
Posted about 1 year ago. Sep 13, 2018 - 09:22 PDT
This incident affected: Circle (Remote Viewing and Playback).