Logitech Circle: Service Issue
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted May 23, 2019 - 16:30 PDT
Monitoring
A fix has been put in place and we are monitoring the situation.
Posted May 23, 2019 - 16:07 PDT
Investigating
We are investigating an issue with the Circle servers causing some cameras utilizing Smart Location to have trouble connecting.
Posted May 23, 2019 - 15:54 PDT
This incident affected: Circle (Video Recording, Video Processing, Video Storage, Remote Viewing and Playback, Public API, Circle Safe Payments, Smart Alerts).