Logitech account email delivery interruption
Incident Report for Logitech
Resolved
The email delivery issue has been resolved, and Logitech Account email delivery is fully operational.
Posted 6 months ago. May 02, 2019 - 15:43 PDT
Monitoring
A small number of emails sent by the Logitech Accounts service are not being delivered. We have contacted the email delivery service and they are working on resolving this issue. Retrying the operation should resolve the issue for the affected customers.
Posted 6 months ago. May 02, 2019 - 12:32 PDT
This incident affected: Logi ID and Alert (App Login, Mac, Windows, Mobile and Web Commander, Remote Viewing and Playback, Remote Control, Subscription Management).