Logitech Circle: Service Issue
Incident Report for Logitech
Resolved
Amazon Web Services has resolved their underlying issue and the Circle service is now operating normally.
Posted 7 months ago. Mar 27, 2019 - 16:48 PDT
Identified
Due to an ongoing issue with Amazon Web Services, there is a small delay in Recordings and Recording Notifications appearing in clients. All recordings are being saved and processed.
Posted 7 months ago. Mar 27, 2019 - 15:45 PDT
This incident affected: Circle (Remote Viewing and Playback, Smart Alerts).