Logitech Circle: 3rd Party API Service Issue

Incident Report for Logitech

Resolved

Amazon Web Services has resolved the issue on their end and the Circle Public API is now operating normally.
Posted Sep 28, 2022 - 14:16 PDT

Identified

An Amazon Web Services service outage is currently causing intermittent failures in the Circle Public API endpoint.
Posted Sep 28, 2022 - 10:30 PDT