Logitech Circle: Service Issue due to Amazon Web Services Problem
Incident Report for Logitech
Resolved
AWS has resolved their issue and Circle services have returned to normal.
Posted Dec 15, 2021 - 08:10 PST
Identified
Amazon Web Services is having a major Internet Connectivity issue that is affecting the Circle Cloud systems. As soon as Amazon Web Services resolves their issue, Circle system should auto recover. For direct status updates from AWS, please see https://status.aws.amazon.com/
Posted Dec 15, 2021 - 07:15 PST
This incident affected: Circle (Video Recording, Video Processing, Video Storage, Remote Viewing and Playback, Public API, Circle Safe Payments, Smart Alerts).