mysqueezebox.com performance issues in EU
Incident Report for Logitech
Resolved
The performance issues on mysqueezbox.com/EU are resolved.
Posted over 2 years ago. Jun 06, 2017 - 12:58 PDT
Investigating
We're currently experiencing slow response times, partially causing service timeouts.
Posted over 2 years ago. Jun 06, 2017 - 09:47 PDT
This incident affected: Squeezebox (Account Management (EU), Player Connection (EU), Music Service API (EU)).