Connectivity issues on mysqueezebox.com
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 17, 2017 - 04:56 PDT
Monitoring
Servers and systems are recovering. Devices connect again.
Posted about 2 years ago. Aug 17, 2017 - 02:56 PDT
Investigating
We're currently seeing connectivity issues with http://mysqueezebox.com . We're working on it.
Posted about 2 years ago. Aug 17, 2017 - 02:11 PDT
This incident affected: Squeezebox (Player Connection (US), Player Connection (EU)).