Account management emails are not delivered
Incident Report for Logitech
Resolved
The incident has been resolved.
Posted about 1 year ago. Aug 28, 2018 - 11:45 PDT
Identified
Account management emails are not being delivered for some customers. The issue is caused by connectivity issues experienced by the email delivery service provider used by Logitech Accounts. As the result, password reset functionality may not work until the issue is resolved. The email provider is aware of the issue and is investigating.
Posted about 1 year ago. Aug 28, 2018 - 09:05 PDT
This incident affected: Logi ID.