Logitech Options+ and G HUB macOS Certificate Issue

Incident Report for Logitech

Resolved

A new ‘patch’ installer for Logitech Options+ and G HUB is now available to fix an issue that caused the apps to stop working on macOS. To download and learn more, please see this page.

https://support.logi.com/hc/articles/37493733117847
Posted Jan 11, 2026 - 23:12 PST

Investigating

A new ‘patch’ installer for Logitech Options+ and G HUB is now available to fix an issue that caused the apps to stop working on macOS. To download and learn more, please see this page.

https://support.logi.com/hc/articles/37493733117847
Posted Jan 08, 2026 - 08:54 PST
This incident affected: Logitech Options+ and Logitech GHUB.