mysqueezebox.com (US): degraded music service availability
Incident Report for Logitech
Resolved
This incident has been resolved.
Posted Jun 23, 2017 - 07:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2017 - 05:09 PDT
Investigating
We're experiencing connection timeouts and response failures on the US web servers.
Posted Jun 23, 2017 - 04:53 PDT
This incident affected: Squeezebox (Account Management (US), Music Service API (US)).